Sage Intacct Error: You cannot update a root level vendor from an entity/restricted user with one entity

Why the Sync Error occurs

There are two reasons why this error may occur:

  • The sync is connected to the entity level, but the object related to the sync error is owned at the root level in Sage Intacct, so Sage Intacct does not allow updates at the entity level
  • The login information used to connect the sync does not have access to the top entity in Sage Intacct, so the sync update is not allowed by Sage Intacct

How to Fix the Sync Error

Two solutions are available, depending on the cause:

Item managed at the root

  1. If the list objects (Chart of Accounts, Vendors, Departments, etc.) are managed at the root level, all updates to these items should only be done in Sage Intacct. Make any necessary updates manually for the erroring items.
  2. Once the information has been manually updated in Sage Intacct, click Resolve or Fix next to the error on the sync status page
  3. Select I've updated this vendor in Sage Intacct; remove this error and sync future updates to clear the error

Sync Login Info

  1. Click Settings
  2. Click Setup under Sync
  3. Click Login Info

Double check the user info:

  • Company ID
  • Username
  • Entity ID

Make sure it is all correct, and that the username has all appropriate permissions in Sage Intacct, based on the necessary permissions listed in the Sage Intacct Sync - Multi-Entity Setup Guide.